VS:EnableItem

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the enable state of a dialog item.

PROCEDURE EnableItem(
dialogID :LONGINT;
componentID :LONGINT;
enableState :BOOLEAN);
def vs.EnableItem(dialogID, componentID, enableState):
    return None

Parameters

dialogID LONGINT the dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier of the component to enable or disable given the state.
enableState BOOLEAN True if the component should be enabled, false otherwise.

Version

Availability: from Vectorworks 2010