VS:DoubleTolerance

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure DoubleTolerance is used with dimensioning procedures to define a tolerance for the most recently created dimension.

PROCEDURE DoubleTolerance(
showVal :BOOLEAN;
boxText :BOOLEAN;
leader :STRING;
trailer :STRING;
topDistance :REAL;
botDistance :REAL);
def vs.DoubleTolerance(showVal, boxText, leader, trailer, topDistance, botDistance):
    return None

Parameters

showVal BOOLEAN Dimension text display flag.
boxText BOOLEAN Boxed text display flag.
leader STRING Dimension leader text string.
trailer STRING Dimension trailer text string.
topDistance REAL Tolerance value text string.
botDistance REAL Tolerance value text string.

Example

VectorScript

LinearDim(-2",2",1",2",-3",0,771,771,0.75);
DoubleTolerance(True,False,'est. ','',1/16",1/16");
{defines a dimension with a double tolerance}

Python

vs.LinearDim(-2,2,1,2,-3,0,771,771,0.75)
vs.DoubleTolerance(True,False,'est. ','',1/16,1/16)

Version

Availability: from MiniCAD4.0