VS:CreateWallStyle

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new Wall Style of the give name. If the name is already in use, the next available name will be used.

FUNCTION CreateWallStyle(
wallStyleName :STRING) : HANDLE;
def vs.CreateWallStyle(wallStyleName):
    return HANDLE

Parameters

wallStyleName STRING The name of the new Wall Style. If the name is already in use, the next available name will be used

Return Value

Returns a handle to the new Wall Style.

Remarks

CJG 6-27-06

Example

VectorScript

PROCEDURE Example;
CONST
wallStyleName = 'Example Wall Style';
VAR
wallStyleHandle :HANDLE;
wdth :REAL;
fill :LONGINT;
pwLeft, pwRight, psLeft, psRight :INTEGER;
boo :BOOLEAN;
BEGIN
wallStyleHandle := CreateWallStyle(wallStyleName);
wdth    := 1";
fill    :=  1; {solid white}
pwLeft  := 14; {in mils}
pwRight := 14; {in mils}
psLeft  :=  2; {solid black}
psRight :=  2; {solid black}
boo := InsertNewComponent(wallStyleHandle, 1, wdth, fill, pwLeft, pwRight, psLeft, psRight);
SetName(wallStyleHandle, wallStyleName); {Reset the wall style name.}
END;
RUN(Example);

Python

def Example():
	wallStyleName = 'Example Wall Style'
	wallStyleHandle = vs.CreateWallStyle(wallStyleName)
	wdth    = 1
	fill    =  1 #{solid white}
	pwLeft  = 14 #{in mils}
	pwRight = 14 #{in mils}
	psLeft  =  2 #{solid black}
	psRight =  2 #{solid black}
	boo = vs.InsertNewComponent(wallStyleHandle, 1, wdth, fill, pwLeft, pwRight, psLeft, psRight)
	vs.SetName(wallStyleHandle, wallStyleName) #{Reset the wall style name.}

Example()

Version

Availability: from VectorWorks12.5