VS:CreateResizableLayout

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new resizable Layout Manager dialog.

Resizable dialogs raise the ResizeDialogC event when resized.

FUNCTION CreateResizableLayout(
dialogTitle :STRING;
hasHelp :BOOLEAN;
defaultButtonName :STRING;
cancelButtonName :STRING;
widthResizable :BOOLEAN;
heightResizable :BOOLEAN) : LONGINT;
def vs.CreateResizableLayout(dialogTitle, hasHelp, defaultButtonName, cancelButtonName, widthResizable, heightResizable):
    return LONGINT

Parameters

dialogTitle STRING
hasHelp BOOLEAN
defaultButtonName STRING
cancelButtonName STRING
widthResizable BOOLEAN
heightResizable BOOLEAN

Remarks

The parameters are the same as CreateLayout, except for widthResizable and heightResizable, which specify that the width and height, respectively, be resizable. A dialog ID is returned by the function.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetEdgeBinding | VS:SetProportionalBinding

VS Functions:

[[VS:SetEdgeBinding]]

| [[VS:SetProportionalBinding]]