VS:CreateImageControl2

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

PROCEDURE CreateImageControl2(
dialogID :LONGINT;
controlID :LONGINT;
widthInPixels :INTEGER;
heightInPixels :INTEGER;
imageSpecifier :DYNARRAY[] of CHAR);
def vs.CreateImageControl2(dialogID, controlID, widthInPixels, heightInPixels, imageSpecifier):
    return None

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier that should be assigned to the control.
widthInPixels INTEGER The width of the control. Use zero to let the image dictate the dimension
heightInPixels INTEGER The height of the control. Use zero to let the image dictate the dimension
imageSpecifier DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012