VS:CreateExtrudeAlongPath/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

輪郭、パスを示す図形から3Dパス図形を作成します。パスの図形属性はNURBS曲線(111)でなければなりません。輪郭の図形属性はNURBS曲線、多角形、曲線、円弧、四角形、隅の丸い四角形、線、長円でなければなりません。

FUNCTION CreateExtrudeAlongPath(
pathHandle :HANDLE;
profileHandle :HANDLE) : HANDLE;
def vs.CreateExtrudeAlongPath(pathHandle, profileHandle):
    return HANDLE

Parameters

pathHandle HANDLE パスのハンドル(NURBS曲線)
profileHandle HANDLE 輪郭のハンドル

Return Value

新しく作成された3Dパス図形のハンドルを返します。その他の場合はNILを返します。

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:ExtrudeAlongPath

VS Functions: [[VS:ExtrudeAlongPath]]