VS:CreateContourCurves

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates contour curves for a solid object given the delta, point on plane and plane normal. If delta is 0, only 1 curve is created, where the specified plane intersects the selected solid.

FUNCTION CreateContourCurves(
inSourceObject :HANDLE;
delta :REAL;
ptOnPlaneX,ptOnPlaneY,ptOnPlaneZ :REAL;
normalX,normalY,normalZ :REAL) : HANDLE;
def vs.CreateContourCurves(inSourceObject, delta, ptOnPlane, normal):
    return HANDLE

Parameters

inSourceObject HANDLE Handle to a solid object
delta REAL Distance between contours
ptOnPlane REAL Point on plane used to define contours
normal REAL Plane's normal vector

Return Value

Returns a HANDLE to a group containing NURBS curves representing the contours.

Example

VectorScript

PROCEDURE Example;
VAR
inSourceObject :HANDLE; 
delta :REAL; 
ptOnPlaneX, ptOnPlaneY, ptOnPlaneZ :REAL; 
normalX, normalY, normalZ :REAL;
h :HANDLE;
BEGIN
inSourceObject := FSActLayer;
delta := 0; {number of slices}
ptOnPlaneX := 0;
ptOnPlaneY := 0;
ptOnPlaneZ := 610;
normalX := 0;
normalY := 0;
normalZ := 1;
h := CreateContourCurves(inSourceObject, delta, ptOnPlaneX, ptOnPlaneY, ptOnPlaneZ, normalX, normalY, normalZ);
END;
RUN(Example);

Python

def Example():
	inSourceObject = vs.FSActLayer()
	delta = 0 #{number of slices}
	ptOnPlaneX = 0
	ptOnPlaneY = 0
	ptOnPlaneZ = 610
	normalX = 0
	normalY = 0
	normalZ = 1
	h = vs.CreateContourCurves(inSourceObject, delta, ptOnPlaneX, ptOnPlaneY, ptOnPlaneZ, normalX, normalY, normalZ)
Example()

Version

Availability: from VectorWorks10.1