VS:BeginGroup

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginGroup creates a new group object in a VectorWorks document. Procedure calls subsequent to BeginGroup and before EndGroup will be included in the new group object. BeginGroup may be called repeatedly to created nested groups of objects.

PROCEDURE BeginGroup;
def vs.BeginGroup():
    return None

Example

VectorScript

BeginGroup;
Rect(-1,1,0.5,0);
Rect(0,1.5,1,0.5);
Oval(-1.5,0.5,-0.5,-0.5);
EndGroup;
{creates a group}

BeginGroup;
Rect(-1,1,0,0.5);
Rect(-1,0.5,-0.5,0);
BeginGroup;
Oval(-0.5,0.5,1,0);
Oval(0,0,1,-0.5);
EndGroup;
EndGroup;
{creates a group comprised of 2 rects and 1 group}

Python

vs.BeginGroup()
vs.Rect(-1,1,0.5,0)
vs.Rect(0,1.5,1,0.5)
vs.Oval(-1.5,0.5,-0.5,-0.5)
vs.EndGroup()
#{creates a group}

vs.BeginGroup()
vs.Rect(-1,1,0,0.5)
vs.Rect(-1,0.5,-0.5,0)
vs.BeginGroup()
vs.Oval(-0.5,0.5,1,0)
vs.Oval(0,0,1,-0.5)
vs.EndGroup()
vs.EndGroup()
#{creates a group comprised of 2 rects and 1 group}

Version

Availability: from All Versions