VS:BeginFloor

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginFloor creates a new floor object in a VectorWorks document. BeginFloor uses 2D object creation procedure calls to define the "template" for the object.

After specifying object procedure calls to define the floor object, you should call EndGroup to complete the column definition and create the actual object.

PROCEDURE BeginFloor(
thicknessDistance :REAL);
def vs.BeginFloor(thicknessDistance):
    return None

Parameters

thicknessDistance REAL Floor thickness.

Example

VectorScript

BeginFloor(6");
Rect(1,1,5,5);
EndGroup;

Python

vs.BeginFloor(6)
vs.Rect(1,1,5,5)
vs.EndGroup()

Version

Availability: from MiniCAD4.0