VS:AlertSetAlwaysDoVal

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the 'always do' value for the AlertQuestionDontShowAgain and AlertInformDontShowAgain standard dialogs.

PROCEDURE AlertSetAlwaysDoVal(
category :STRING;
item :STRING;
value :INTEGER);
def vs.AlertSetAlwaysDoVal(category, item, value):
    return None

Parameters

category STRING category name of the value.
item STRING item name in the category.
value INTEGER new value for the default. Pass in -1 for the entry to be cleared out and the dialog to show up again.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:AlertQuestionDontShowAgain | VS:AlertInformDontShowAgain

VS Functions:

[[VS:AlertQuestionDontShowAgain]]

| [[VS:AlertInformDontShowAgain]]