VS:AlertCritical

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Informs the user of a serious problem that requires intervention or correction before work can continue.

PROCEDURE AlertCritical(
text :STRING;
advice :STRING);
def vs.AlertCritical(text, advice):
    return None

Parameters

text STRING The information to be displayed.
advice STRING The text to be added in a smaller font under the main information message

Remarks

Created by TTF 1/18/2005

Example

VectorScript

PROCEDURE Example;
BEGIN
AlrtDialog('AlrtDialog');
AlertInform('AlertInform', 'advice', FALSE);
AlertCritical('AlertCritical', 'advice');
Message(YNDialog('YNDialog'));
Message(AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'));
END;
RUN(Example);

Python

def Example():
	vs.AlrtDialog('AlrtDialog')
	vs.AlertInform('AlertInform', 'advice', False)
	vs.AlertCritical('AlertCritical', 'advice')	
	vs.Message(vs.YNDialog('YNDialog'))
	vs.Message(vs.AlertQuestion('question', 'advice', 1, 'ok', 'cancel', 'a', 'b'))
Example()

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:AlertInform | VS:AlertQuestion

VS Functions:

[[VS:AlertInform]]

| [[VS:AlertQuestion]]