VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetKeyDisplayString

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Converts the keycodes obtained by the GetShortcutKeys function.

virtual VCOMError VCOM_CALLTYPE GetKeyDisplayString(
char inKeyCode,
TXString &outDisplayString ) = 0;

Parameters

inKeyCode char is a keycode from TSpecialKeys or TConstraintsKeys
outDisplayString TXString & on output, if successful, is the string equivalent of the keycode.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.