VCOM:VectorWorks:UI:IProgressDialog::IncrementMeter

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IProgressDialog

Increase progress meter by the specified step.

virtual VCOMError VCOM_CALLTYPE IncrementMeter(
Uint16 step) = 0;

Parameters

step Uint16 Increment the meter with the specified step.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.