VCOM:VectorWorks:UI:IInfoBar::StartProgressIndicator

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IInfoBar

Shows the progress indicator in the Info bar.

virtual VCOMError VCOM_CALLTYPE StartProgressIndicator(
const TXString& strProgressLabel,
Uint16 nMaxProgress) = 0;

Parameters

strProgressLabel const TXString& The progress label that appears before the progress indicator.
nMaxProgress Uint16 Maximum progress value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.