VCOM:VectorWorks:UI:IIcon::GetDimensions

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IIcon

Get dimensions (width and height) of the icon that is set into this instance.

virtual VCOMError VCOM_CALLTYPE GetDimensions(
Sint16& outWidth,
Sint16& outHeight) = 0;

Parameters

outWidth Sint16& Output parameter. Return width of the icon set in the instance. Result in pixels.
outHeight Sint16& Output parameter. Return height of the icon set in the instance. Result in pixels.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.