VCOM:VectorWorks:ISDK::WSToolSetAddToolChildToTool

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This function adds a sub-tool to a tool hierarchy in a tool set.


@param inWorkspaceReference is a reference to the XML Workspace file.

@param inToolSetIdentifier is the tool set we are interested in.

@param inParentToolIdentifier is the parent tool that we are going to add a sub-tool to.

@param inChildToolIdentifier is the new child tool we are adding to the list of tools in this collection.

@return true if the operation was successful.

virtual bool WSToolSetAddToolChildToTool(
long inWorkspaceReference,
const TXString& inToolSetIdentifier,
const TXString& inParentToolIdentifier,
const TXString& inChildToolIdentifier)

Parameters

long inWorkspaceReference No information available.
constTXString& inToolSetIdentifier No information available.
constTXString& inParentToolIdentifier No information available.
constTXString& inChildToolIdentifier No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009