VCOM:VectorWorks:ISDK::UpdateConstraintModel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This updates the geometry of the constraint model for all the objects that were explicitly added to the model (through the useSelection flag or by being passed into CreateConstraintModel or AddToConstraintModel) to their current location and geometry in the drawing. Then it attempts to resolve all the parametric constraints in the model, setting any node that was modified by user action to be unmovable. If a constraint could not be resolved, this function returns false, and an Undo call should be made.

virtual bool UpdateConstraintModel( )

Parameters

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009