VCOM:VectorWorks:ISDK::TrackTool

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Used during the kToolDoPick case of a tool definition. Returns in overObject the object the cursor is currently over (or nil if the cursor is not over any object) and in overPart one of cursOnNothing (object is not over any snappable object), cursOnObject (cursor is over an object), or cursOnHandle (object is over a selected object's handle). TrackTool only responds to 'snappable' objects, i.e. objects that are on a currently editable or snappable layer. code returns a long that is specific to each overPart message.

virtual void TrackTool(
MCObjectHandle& overObject,
short& overPart,
long& code)

Parameters

MCObjectHandle& overObject No information available.
short& overPart No information available.
long& code No information available.

Version

Availability: from Vectorworks 2009