VCOM:VectorWorks:ISDK::SetWorksheetCellTextFormat

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the specified text format for the specified worksheet cells.


Text Format (style) constants:

kTextStylePlain = 0

kTextStyleBold = 1

kTextStyleItalic = 2

kTextStyleUnderline = 4

kTextStyleOutline = 8

kTextStyleShadow = 16


Note: Outline and Shadow only display on the Mac

virtual void SetWorksheetCellTextFormat(
MCObjectHandle worksheet,
const Point& topLeftCell,
const Point& bottomRightCell,
short fontIndex,
short size,
short style)

Parameters

MCObjectHandle worksheet No information available.
constPoint& topLeftCell No information available.
constPoint& bottomRightCell No information available.
short fontIndex No information available.
short size No information available.
short style No information available.

Version

Availability: from Vectorworks 2009