VCOM:VectorWorks:ISDK::SetViewMatrix

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

A low-level routin that sets the view matrix of the specified layer to theMatrix. This does not handle other factors involved with changing the view such as redrawing, re-rendering, etc.

virtual void SetViewMatrix(
MCObjectHandle theLayer,
const TransformMatrix& theMatrix)

Parameters

MCObjectHandle theLayer No information available.
constTransformMatrix& theMatrix No information available.

Version

Availability: from Vectorworks 2009