VCOM:VectorWorks:ISDK::SetTrapeziumAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Set trapezium dormer attributes.


dormerID: Identifies the which dormer for which to set the values.


useHeight: Set to true if the next value is the height of the dormer, otherwise set to false if the next value is the depth (front to back) of the dormer.

heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: Dimension of bottom front edge of the dormer, left to right.


useTopWidth: True if using a dimension to set the width of the dormer roof. False if the top width of the dormer is determined by the left and right slope. The topWidth is exclusive of leftSlope & rightSlope.

topWidth: Dimension of the roof of the dormer.

leftSlope: Angle of left dormer wall.

rightSlope: Angle of right dormer wall.


topSlope: Angle of the roof of the dormer.

virtual bool SetTrapeziumAttributes(
MCObjectHandle object,
const short dormerID,
bool useHeight,
WorldCoord heightDepthValue,
WorldCoord bottomWidth,
bool useTopWidth,
WorldCoord topWidth,
double_param leftSlope,
double_param rightSlope,
double_param topSlope)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool useHeight No information available.
WorldCoord heightDepthValue No information available.
WorldCoord bottomWidth No information available.
bool useTopWidth No information available.
WorldCoord topWidth No information available.
double_param leftSlope No information available.
double_param rightSlope No information available.
double_param topSlope No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009