VCOM:VectorWorks:ISDK::SetRoofAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Set the properties of the roof.


genGableWall: Set to true to have a wall created at gable ends of the roof. Otherwise no object will be inserted.

bearingInset is where the weight of the roof rests on the wall. This is an inset from the defining edge of the roof plan.

miterType: Specify 1 for a vertical miter, 2 for horizontal miter, 3 for a double miter cut, and 4 for a square end miter cut. vertMiter: This is used only with the double miter type; it specifies the vertical length of the miter cut.

virtual void SetRoofAttributes(
MCObjectHandle object,
bool genGableWall,
WorldCoord bearingInset,
WorldCoord roofThick,
short miterType,
WorldCoord vertMiter)

Parameters

MCObjectHandle object No information available.
bool genGableWall No information available.
WorldCoord bearingInset No information available.
WorldCoord roofThick No information available.
short miterType No information available.
WorldCoord vertMiter No information available.

Version

Availability: from Vectorworks 2009