VCOM:VectorWorks:ISDK::SetRenderMode

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This sets the render mode of the specified layer and takes care of regenerating the rendering. If immediate is true, then all rendering will take place before the call returns. Otherwise, any rendering that can take place in the background will be postponed until program execution re-enters the main event loop. doProgress controls whether progress information is displayed during the operation.

virtual bool SetRenderMode(
MCObjectHandle theLayer,
short newRenderMode,
bool immediate,
bool doProgress)

Parameters

MCObjectHandle theLayer No information available.
short newRenderMode No information available.
bool immediate No information available.
bool doProgress No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009