VCOM:VectorWorks:ISDK::SetPtrSize

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the size of pointer p to size and returns the new pointer. If p can be resized without being moved, then the result will be the same address as p. If p has be moved to be successfully resized then the result is the new address of the pointer and the original address is no longer valid. If the resize is not successful, then the result is nil and p is untouched.

virtual VoidPtr SetPtrSize(
void* p,
size_t size)

Parameters

void* p No information available.
size_t size No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009