VCOM:VectorWorks:ISDK::SetObjectVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Changes the property of an object. The selector chooses which property will be changed, and the value specifies what it should be changed to have.

virtual bool SetObjectVariable(
MCObjectHandle theObject,
short setSelector,
const TVariableBlock& value)

Parameters

MCObjectHandle theObject No information available.
short setSelector No information available.
constTVariableBlock& value No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009