VCOM:VectorWorks:ISDK::SetObjectName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets h's name to the specified string. To un-name an object, set its name to the empty string, i.e. 'SetObjectName(h, "\p");'. SetObjectName may return one of three error codes: noErr (there was no error), nameNotUniqueErr (some other object already has the same name), or nameTableFullErr (no new names can be added; you must un-name some objects first.) You are limited to approximately 16,000 named objects in a single file, though you may run out of memory before reaching this limit.

virtual GSError SetObjectName(
MCObjectHandle h,
const InternalName name)

Parameters

MCObjectHandle h No information available.
constInternalName name No information available.

Return Value

On error returns: noErr

Version

Availability: from Vectorworks 2009