VCOM:VectorWorks:ISDK::SetObjectBounds

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the bounding box for the object h. If an object is a simple object (a rectangle or an oval) then its bounding box is a defining attribute and changes to it will have the expected effect. If the object is a more complex object (a wall or dimension) then the bounding box is a derived attribute and changes to it will not affect the definition of the object. However, since MiniCad uses the bounding box in drawing the object, changing the bounding box of a complex object will have a noticable affect manifested as a drawing error. This error is only temporary as the bounding box will be correctly reset after certain operations. A general technique for achieving the same end is to use MoveObject() and ScaleObject().

virtual void SetObjectBounds(
MCObjectHandle h,
const WorldRect& bounds)

Parameters

MCObjectHandle h No information available.
constWorldRect& bounds No information available.

Version

Availability: from Vectorworks 2009