VCOM:VectorWorks:ISDK::SetHandleSize

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the size of "handle" to "size" bytes. If the size of the handle increases, then the new space at the end is filled with random data. If the size decreases, then the data in the handle is truncated. If the allocation fails, then the function result is false.

virtual bool SetHandleSize(
GSHandle handle,
size_t size)

Parameters

GSHandle handle No information available.
size_t size No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009