VCOM:VectorWorks:ISDK::SetEdgeBinding

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Binds edges of a control to its parent. Binding to an edge indicates that the control will maintain a predictable distance from one of its sides to the corresponding side of its parent. Bindings can be either fixed or proportional. Fixed bindings maintain a constant distance from their parent. Proportional bindings maintain a distance that is a ratio of the initial position to the width (or height, as appropriate) of the parent.


This function sets bindings to be fixed. To change any of them to be proportional, use SetProportionalBinding.

virtual void SetEdgeBinding(
long dialogID,
long itemID,
CBbool boundToLeft,
CBbool boundToRight,
CBbool boundToTop,
CBbool boundToBottom)

Parameters

long dialogID No information available.
long itemID No information available.
CBbool boundToLeft No information available.
CBbool boundToRight No information available.
CBbool boundToTop No information available.
CBbool boundToBottom No information available.

Version

Availability: from Vectorworks 2009