VCOM:VectorWorks:ISDK::SetDXFColorToLineWeight

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This sets DXF import system to map the given DXF color index to the given lineweight in mils. A valid DXF color index is from 0 to 255 (0 = kDXFColorByBlock) and a valid lineweight in mils is 0 to 255 (0 is invisible and should normally not be used). This map is used to initialize the mapping dialog on import, and to control mapping when doing a silent import with GS_ImportDXFMac() or GS_ImportDXFWin(). During DXF import, any unmapped values will be set to a default value. To view the current mapping, use GS_GetDXFColorToLineWeight(). Constants for standard colors (kDXFCyan, etc) are defined in MiniCadCallBacks.h.

virtual void SetDXFColorToLineWeight(
const short inDXFColorIndex,
const short inLineWeight)

Parameters

constshort inDXFColorIndex No information available.
constshort inLineWeight No information available.

Version

Availability: from Vectorworks 2009