VCOM:VectorWorks:ISDK::SetCustomDimensionStandardVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Changes a property of a custom dimension standard. The index specifies which custom dimension to change. The nine built-in dimension standards use indexes 1 thru 9 and cannot be changed with this function. Custom dimensions use indexes 0 thru -8, and those are the dimension index values that should be used with this function. The selector chooses which property will be changed, and the value specifies what that property should be changed to. This function returns false if an invalid dimension index or field selector is specified.

virtual bool SetCustomDimensionStandardVariable(
short dimensionIndex,
short fieldSelector,
const TVariableBlock& value)

Parameters

short dimensionIndex No information available.
short fieldSelector No information available.
constTVariableBlock& value No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009