VCOM:VectorWorks:ISDK::SetComponentUsePenClassAttr

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the use class attributes flags of the pens of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentUsePenClassAttr(
MCObjectHandle object,
short componentIndex,
Boolean useLeftPenClassAttributes,
Boolean useRightPenClassAttributes) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
useLeftPenClassAttributes Boolean Whether or not the component will use class attributes for its left pen.
useRightPenClassAttributes Boolean Whether or not the component will use class attributes for its right pen.

Version

Availability: from Vectorworks 2009