VCOM:VectorWorks:ISDK::SetComponentName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the name of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentName(
MCObjectHandle object,
short componentIndex,
const TXString& componentName) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
componentName const TXString& The name of the component.

Version

Availability: from Vectorworks 2009