VCOM:VectorWorks:ISDK::SetComponentFillColors

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the fore and back fill colors of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentFillColors(
MCObjectHandle object,
short componentIndex,
ColorRef fillForeColor,
ColorRef fillBackColor) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
fillForeColor ColorRef The fore color of the fill.
fillBackColor ColorRef The back color of the fill.

Version

Availability: from Vectorworks 2009