VCOM:VectorWorks:ISDK::SetBreak

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the break, specified by index, to the break information specified. When breakType == kSymbolBreak, a duplicate of the symbol handle contained in the breakData paramater is inserted and the handle pointed to by breakData is updated with the handle to the new symbol. If the original symbol was already in the wall, you should NOT dereference any handles to that symbol because it will be deleted by the next call to ResetWall.


To change the break of an existing symbol without duplicating that symbol, set the symbol handle in breakData to nil prior to calling SetBreak. This will copy all of the passed in break data, including the offset, into the break but will not create a new symbol instance.

virtual void SetBreak(
MCObjectHandle theWall,
short index,
WorldCoord off,
short breakType,
void* breakData)

Parameters

MCObjectHandle theWall No information available.
short index No information available.
WorldCoord off No information available.
short breakType No information available.
void* breakData No information available.

Version

Availability: from Vectorworks 2009