VCOM:VectorWorks:ISDK::SaveActiveDocumentPath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Saves the active document to the specified file without presenting any dialogs to the user (other than possible error alerts).

You can save over the currently active document by passing in its file identifier, but otherwise this call will not overwrite existing disk documents.

virtual GSError VCOM_CALLTYPE SaveActiveDocumentPath(
IFileIdentifier* pFileID) = 0;

Parameters

pFileID IFileIdentifier* The file that needs to be saved into.

Version

Availability: from Vectorworks 2009