VCOM:VectorWorks:ISDK::RegisterNotificationProcedure

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Registers the procedure passed in the first parameter with the VectorWorks gNotification object. When an internal event matching that specified by the whichChange parameter occurs, the registered procedure will be called and can take appropriate action. See MCNotify.h for notification constants which can be used with this system.

virtual bool RegisterNotificationProcedure(
StatusProcPtr proc,
OSType whichChange)

Parameters

StatusProcPtr proc No information available.
OSType whichChange No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009