VCOM:VectorWorks:ISDK::RegisterExternal

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This registers an external code resource so that it can be called from another external. The codeResID & codeResType fields specify which resource contains the main code segment. It returns the ID by which the code segment can be called. NOTE: do not register files with a file type of 'XCOD' as they are registered automatically at startup. they will always use XCOD 50 resources as the main code segment.

virtual long RegisterExternal(
const TXString& fileName,
short codeResID,
OSType codeResType)

Parameters

constTXString& fileName No information available.
short codeResID No information available.
OSType codeResType No information available.

Return Value

On error returns: -1

Version

Availability: from Vectorworks 2009