VCOM:VectorWorks:ISDK::PreviewSetup

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This is the setup call for a set of routines supporting interactive rotation of 3D objects. This is the behavior the user sees when using 3D view specification tools like walkthrough and flyover. To use this service, first get the current view matrix with GetViewMatrix. Then create a preview with PreviewSetup. You can then repeatedly modify the matrix, call SetViewMatrix and call PreviewDrawFrame in a loop until the desired view is chosen. The view change would typically respond to input from the user, but QuickTime export uses the same calls to display animation previews. You must then call PreviewFinish, and if you want to permanently alter the view, you must call NewCurrentViewMatrix to set the new view.

virtual Handle PreviewSetup(
bool doDynamicSpeedups = true,
double_param targetFPS = 0.0,
bool drawGroundPlane = true,
bool drawPage = true,
bool drawCropRect = true)

Parameters

booldoDynamicSpeedups= true No information available.
double_paramtargetFPS= 0.0 No information available.
booldrawGroundPlane= true No information available.
booldrawPage= true No information available.
booldrawCropRect= true No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009