VCOM:VectorWorks:ISDK::PointOnPolyEdge

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns true if h is a polyNode, curveNode or polylineNode and checkpt is within checkRadius of the edge of the polygon object. Polyline objects are converted to polygons.

virtual bool PointOnPolyEdge(
const WorldPt& checkPt,
MCObjectHandle h,
WorldCoord checkRadius)

Parameters

constWorldPt& checkPt No information available.
MCObjectHandle h No information available.
WorldCoord checkRadius No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009