VCOM:VectorWorks:ISDK::PointInsidePoly

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns true if theObject is a polyNode or curveNode and checkpt is inside of the polygon object. Polyline objects are converted to polygons.

virtual bool PointInsidePoly(
const WorldPt& checkPt,
MCObjectHandle h)

Parameters

constWorldPt& checkPt No information available.
MCObjectHandle h No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009