VCOM:VectorWorks:ISDK::PlaySoundResource

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Plays a sound resource. Set async true to play the sound asynchronously, or false to play the sound synchronously. Set forcePlay true to ignore the Use Sound preference. Set forcePlay false to observe the Use Sound preference.

virtual CBbool PlaySoundResource(
Handle soundResource,
CBbool async,
CBbool forcePlay)

Parameters

Handle soundResource No information available.
CBbool async No information available.
CBbool forcePlay No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009