VCOM:VectorWorks:ISDK::PlaceSymbolN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Places an instance of the symbol <definition> at the specified location, rotated by <rotation> degrees. If definition is nil, PlaceSymbol does nothing.

PlaceSymbolN creates the symbol but does not insert it into the document.

virtual MCObjectHandle PlaceSymbolN(
MCObjectHandle definition,
const WorldPt& location,
double_param rotation = 0.0)

Parameters

MCObjectHandle definition No information available.
const WorldPt& location No information available.
double_param rotation=0.0 No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009