VCOM:VectorWorks:ISDK::NonUndoableActionOK

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Posts a dialog informing the user that the action that is about to be performed is not undo-able. If the user clicks OK, this function returns true. If the user clicks NOT OK, this function returns false. If the "Show Undo Warnings" preference is turned off, NO dialog is presented, a user response of OK is assumed, and this function returns true. If this function returns true, you MUST call GS_SetUndoMethod(kUndoNone) before proceeding to change objects.

virtual bool NonUndoableActionOK( )

Parameters

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009