VCOM:VectorWorks:ISDK::NewDataObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a new data object of size objectSize with the specified tag and attaches it to the object attachTo. If attachTo is nil, the data object is still created, but is not attached to anything; you must then use AttachAuxObject to attach it to another object. Calling GetObjectType on a data object will return userDataNode. Graphsoft reserves all tags consisting entirely of lowercase letters. [Note: While data objects are intended to only appear as auxiliary objects, you may insert them into the normal drawing list with no ill effects. However, using excessive numbers of them this way will slow down basic operations such as picking, snapping, and redrawing.]

virtual MCObjectHandle NewDataObject(
MCObjectHandle attachTo,
OSType tag,
size_t objectSize)

Parameters

MCObjectHandle attachTo No information available.
OSType tag No information available.
size_t objectSize No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009