VCOM:VectorWorks:ISDK::Moments3D

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the moments of inertia of a 3D object about the x, y, and z axes of

a point at the center of gravity of the object. The function returns TRUE if

the values were found.

virtual bool Moments3D(
MCObjectHandle h,
double_gs &Ixx,
double_gs &Iyy,
double_gs &Izz)

Parameters

MCObjectHandle h No information available.
double_gs &Ixx No information available.
double_gs &Iyy No information available.
double_gs &Izz No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009