VCOM:VectorWorks:ISDK::IsValidWorksheetRange

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Determines if specified range is valid for the specified worksheet.

NOTE: A determination that a range is valid only means that the specified range falls within a range of 0 to the current number of worksheet rows and 0 to the current number of worksheet columns. A valid range does not imply that every worksheet SDK function will accept that range. The user should always note any specific cell and cell range restrictions of a call they may use.

virtual bool IsValidWorksheetRange(
MCObjectHandle worksheet,
const Point& topLeftCell,
const Point& bottomRightCell)

Parameters

MCObjectHandle worksheet No information available.
constPoint& topLeftCell No information available.
constPoint& bottomRightCell No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009