VCOM:VectorWorks:ISDK::IsValidWorksheetCell

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Determines if specified cell is valid for the specified worksheet.

NOTE: A determination that a cell is valid only means that the specified cell falls within a range of 0 to the current number of worksheet rows and 0 to the current number of worksheet columns. A valid cell does not imply that every worksheet SDK function will accept that cell. The user should always note any specific cell and cell range restrictions of a call they may use.

virtual bool IsValidWorksheetCell(
MCObjectHandle worksheet,
const Point& cell)

Parameters

MCObjectHandle worksheet No information available.
constPoint& cell No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009