VCOM:VectorWorks:ISDK::IsInStandardFolderN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns true if the given file path is under the given standard folder class. 'outFolderPath' will be set to the standard folder that the file is under if successful.

folderClass is one of the folder constants in FolderSpecifiers.h

virtual bool IsInStandardFolderN(
FolderSpecifier folderClass,
const char* filePath,
char outFolderPath[1024])

Parameters

FolderSpecifier folderClass No information available.
constchar* filePath No information available.
char outFolderPath[1024] No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009