VCOM:VectorWorks:ISDK::InsertObjectBefore

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Unlinks h from wherever it currently is in the drawing and inserts it immediately before beforeObject. Note that you can use this routine to move object in to and out of containers. For example, to make an object the first object in a group, use 'InsertObjectBefore(cbp, h, FirstMemberObj(cbp, aGroup))'. The same caveats about what types of objects may be inserted where that apply to InsertObjectAfter also apply to InsertObjectBefore.

virtual void InsertObjectBefore(
MCObjectHandle h,
MCObjectHandle beforeObject)

Parameters

MCObjectHandle h No information available.
MCObjectHandle beforeObject No information available.

Version

Availability: from Vectorworks 2009